02.ip addressing lab

Upload: zitro01

Post on 03-Apr-2018

216 views

Category:

Documents


0 download

TRANSCRIPT

  • 7/28/2019 02.IP Addressing Lab

    1/4

    The Bryant Advantage Ultimate CCNA Lab Workbook

    Chris Bryant, CCIE #12933 - www.thebryantadvantage.com Back To Index

    IP Addressing Lab

    Youve got to know how to assign IP addresses to pass the CCNA exams,and youre about to get a lot of practice. Were going to configurephysical interfaces, logical interfaces, and loopback interfaces.

    You also need to know how to name a router. We do this with thehostname command. Change the names of the routers to whatever youlike, but after practicing this command, change the names back to R1,

    R2, R3, SW1, and SW2. Those are the names youll see through the labworkbook.

    R1#conf t

    Enter configuration commands, one per line. End with CNTL/Z.

    R1(config)#hostname Router1Router1(config)#hostname R1

    R1(config)#^Z

    R1#

    The ^Z youll see on the screen is what ctrl-z sends to the console, and

    of course, you know from your CCNA reading that ctrl-z brings you backout to the enable prompt.

    Notice that the hostname command took effect immediately, as all globalcommands do.

    Lets take a look at the networks well be configuring.

    Here's a drawing of the network (ignore the OSPF commands -- for

    now :) .

    Network Type Network / SubnetMask

    Ethernet (R2, R3) 172.23.23.0 /27

    Serial to Frame Relay Cloud (All) 172.12.123.0 /24

    Directly Connected Serial Interfaces(R1, R3)

    172.12.13.0 /24

    Router 1 Loopback Address 1.1.1.1 / 32

    Router 2 Loopback Address 2.2.2.2 /32

    Router 3 Loopback Address 3.3.3.3 / 32

  • 7/28/2019 02.IP Addressing Lab

    2/4

    Lets start with R1. DO NOT OPEN THE SERIAL 0 INTERFACE.

    R1#conf t

    Enter configuration commands, one per line. End with CNTL/Z.

    R1(config)#interface serial0

    R1(config-if)#ip address 172.12.123.1 255.255.255.0

    R1(config-if)#interface serial1

    R1(config-if)#ip address 172.12.13.1 255.255.255.0

    R1(config-if)#no shut

    00:18:34: %LINK-3-UPDOWN: Interface Serial1, changed state to down

    R1(config-if)#interface loopback0

    R1(config-if)#ip address 1.1.1.1 255.255.255.255

    R1(config-if)#write (OR copy run start)

    Building configuration.

    Dont worry about the line protocols being down; other labs will take careof that. All were doing right now is setting the IP addresses and openingthe interfaces. Get used to saving your work as often as possible withwr, short for write. Use IOS Help to see the options and the defaults.(Remember, IOS Help is the question mark symbol.) You can also usecopy run start.

    Dont forget to open the interfaces! If youre having a connectivity problemand run a command such as show interface ethernet 0, and you see thefollowing, it means the interface is manually closed and needs to be

  • 7/28/2019 02.IP Addressing Lab

    3/4

    opened with the no shutdown command.

    R2#show interface ethernet0

    Ethernet0 is administratively down, line protocol is down

    Now configure R2s interfaces. Do not open interface serial0.

    R2(config)#interface serial0

    R2(config-if)#encap frame

    R2(config-if)#no frame inverse-arp

    R2(config-if)#interface serial 0.123 multipoint

    R2(config-subif)#ip address 172.12.123.2 255.255.255.0

    R2(config-if)#interface ethernet0

    R2(config-if)#ip address 172.23.23.2 255.255.255.224

    R2(config-if)#no shut

    00:28:45: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up

    00:28:46: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0,

    changed state to up

    R2(config-if)#interface loopback0R2(config-if)#ip address 2.2.2.2 255.255.255.255

    R2(config-if)#^Z

    R2#

    Note that you configured frame relay on R2. That allows us to create themultipoint subinterface. Frame Relay will be covered completely in a laterlab, but you cannot create that multipoint interface until youve enabledframe relay.

    Also notice that you dont have to run no shuton a loopback interface.(Its not wrong if you do, but you dont have to.)

    Lets configure R3s interfaces. Do not open interface serial0.

    R3#conf t

    Enter configuration commands, one per line. End with CNTL/Z.

    R3(config)#interface serial 0

    R3(config-if)#encap frame

    R3(config-if)#no frame inverse-arp

    R3(config-if)#interface serial0.31 point-to-point

    R3(config-subif)#ip address 172.12.123.3 255.255.255.0

    R3(config-subif)#interface serial 1

    R3(config-if)#ip address 172.12.13.3 255.255.255.0

    R3(config-if)#no shut

    00:33:32: %LINK-3-UPDOWN: Interface Serial1, changed state to up

    00:33:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed

    state to up

    R3(config-if)#interface ethernet0

    R3(config-if)#ip address 172.23.23.3 255.255.255.224

    R3(config-if)#no shut

    00:33:46: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up

    00:33:47: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0,

    changed sta te to up

    R3(config-if)#interface loopback0

    00:33:54: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed

  • 7/28/2019 02.IP Addressing Lab

    4/4

    state to down

    R3(config-if)#ip address 3.3.3.3 255.255.255.255

    Again, note that you configured frame relay on the serial0 physicalinterface, then created a point-to-point subinterface. The Serial0 physicalinterface then had to be opened.

    I urge you to not just walk through these labs, but to use the showanddebugcommands youll read about in this book, in my Ultimate CCNAStudy Guide, and to use IOS Help often to see the other options. Takeadvantage of the fact that youre working with real Cisco routers andswitches, not "router simulators".

    You do not need to configure IP addresses on the switches.

    Theres another command Id like to introduce you to, since we all mistypefrom time to time. Notice what happens when you mistype a commandon a Cisco router:

    R3#hudjgmg

    Translating "hudjgmg"...domain server (255.255.255.255)

    % Unknown command or computer name, or unable to find computer address

    By default, a Cisco router or switch is going to attempt to resolve amistyped command via DNS. Thats what the domain server is that itslooking for, and of course you know that 255.255.255.255 is a layer 3broadcast.

    This only takes about 15 seconds to come back with the unknown

    command line in a practice lab, but it can take much longer in aproduction network. To disable this default behavior, use the globalcommand no ip domain-lookup on each device in your pod. Notice thatimmediately after using this command, the router tries to resolve thecommand locally but does not send the broadcast out.

    R3#conf t

    Enter configuration commands, one per line. End with CNTL/Z.

    R3(config)#no ip domain-lookup

    R3(config)#^Z

    R3#jfujjke

    Translating "jfujjke"

    % Unknown command or computer name, or unable to find computer address

    As with all commands you read about and practice with in my books, donot run a command on a production network unless you are sure of theresult. VERY sure. This is particularly true of the debugs youll be using inmy labs.

    Congratulations! Youve now configured plenty of IP addresses. If youreconfronted with that task on one of your CCNA exams, youre more thanready. Just dont forget to open the interfaces on exam day!

    Back To Index

    Copyright 2011 The Bryant Advantage. All Rights Reserved.