configuring routers

34
Configuring Routers

Upload: alder

Post on 12-Jan-2016

73 views

Category:

Documents


1 download

DESCRIPTION

Configuring Routers. Oh No! I’ve got to program a router! . What do I have to do. Log on to the router. Router> Router>enable Router# Router#config t. Config t is the place to be!. Name the router!. Step One. Router(config)#hostname Lab-A. Lab-A. - PowerPoint PPT Presentation

TRANSCRIPT

Page 1: Configuring Routers

Configuring Routers

Page 2: Configuring Routers

Oh No! I’ve got to program a router!

What do I have to do

Page 3: Configuring Routers

Router>

Router>enable

Router#

Router#config t

Config t is the place to be!

Log on to the router

Page 4: Configuring Routers

Name the router!

Router(config)#hostname Lab-A

Step One

Lab-A

Page 5: Configuring Routers

Password protect the Privilege Mode

Step Two

Lab-A(config)#enable secret class

 

enable secret 5 $1$emBK$WxqLahy7YOAf0nifub.hU

Results in:PasswordCommands

Page 6: Configuring Routers

Configure the Interfaces

Step Three

Lab-A(config)#interface serial0

Lab-A(config-if)#

(Note prompt change)

Page 7: Configuring Routers

Address the Interface(S0)

Lab-A(config-if)#ip address 201.100.11.1 255.255.255.0

Ip address Subnet mask

S0=201.100.11.1S0

Page 8: Configuring Routers

Clock ticks MUST be set between routers on the interface with the serial cable DCE end.

Serial0 is where the DCE connects in our

lab.

Page 9: Configuring Routers

We use Serial0

• Lab-A(config-if)#clock rate 56000

Page 10: Configuring Routers

Address the next Interface (E0)

Lab-A(config-if)#ip address 192.5.5.1 255.255.255.0

Lab-A(config-if)#interface ethernet0

(This changes to program interface e0)

S0=201.100.11.1

E0=192.5.5.1E0

S0

Page 11: Configuring Routers

Address the next Interface (e1)

Lab-A(config-if)#ip address 205.7.5.1 255.255.255.0

Lab-A(config-if)#interface ethernet1

(This changes to program interface e1)

S0=201.100.11.1

E0=192.5.5.1

E1=205.7.5.1

S1=No address

E1S0

E0

Page 12: Configuring Routers

Control z

Lab-A#

Lab-A#show running-config

Page 13: Configuring Routers

Results:

• version 12.0

• service timestamps debug uptime

• service timestamps log uptime

• no service password-encryption

• service udp-small-servers

• service tcp-small-servers

• !

• hostname Lab-A

• !

• enable secret 5 $1$emBK$WxqLahy7YOAf0nifub.hU.

• !

• ip subnet-zero

--More--

Page 14: Configuring Routers

interface Ethernet0

ip address 192.5.5.1 255.255.255.0

no ip directed-broadcast

shutdown

!

interface Ethernet1

ip address 205.7.5.1 255.255.255.0

no ip directed-broadcast

shutdown--More--

Page 15: Configuring Routers

interface Serial0

ip address 201.100.11.1 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

clockrate 56000

shutdown

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

Page 16: Configuring Routers

Like people, routers have to talk to one another!

Page 17: Configuring Routers

Like people, routers have to talk to one another!

Step Four

Set up routing protocols

Page 18: Configuring Routers

Routing Protocols:

RIP RIPv2

IGRP EIGRP

OSPF

Page 19: Configuring Routers

Set up the routing protocol

Lab-A(config)#router rip

Lab-A(config-router)# version 2

Lab-A(config-router)#network 192.5.5.0

Lab-A(config-router)#network 207.7.5.0

Lab-A(config-router)#network 201.100.11.0

(Note prompt change)

Page 20: Configuring Routers

Note!

• You have to configure for EACH network

• (remember network # is the “wire” #)

• Each network is on a separate line

• Hit Control z to activate and return to:

• Lab-A#

Page 21: Configuring Routers

Lab-A#show run

!

router rip

version 2

network 192.5.5.0

network 201.100.11.0

network 205.7.5.0

!

(router portion of show run)

Page 22: Configuring Routers

Control Access

Control and secure access from:

CONSOLE

VTY (telnet)

AUX (modem)

Page 23: Configuring Routers

Control Access

Step Five

Lab-A(config)#line console 0

Lab-A(config-line)#password cisco

(Note prompt change)

Lab-A(config-line)#login

Page 24: Configuring Routers

Continue

Lab-A(config)#line vty 0 4

Lab-A(config-line)#password cisco

Lab-A(config-line)#login

Page 25: Configuring Routers

Control Z(typing the word “exit” at the prompt takes

you up one level)

Lab-A#show run will give the following results:

line con 0

password cisco

login

transport input none

line aux 0

line vty 0 4

password cisco

login

Page 26: Configuring Routers

Want to save time and move fast between routers?

Step Six

Page 27: Configuring Routers

A REAL time Saver!

Lab-A(config)#ip host Lab-A 192.5.5.1 205.7.5.1 201.100.11.1

Lab-A(config)#ip host Lab-B 219.17.100.1 199.6.13.1 201.100.11.2

Lab-A(config)#ip host Lab-C 223.8.151.1 204.204.7.1 199.6.13.2

Lab-A(config)#ip host Lab-D 210.93.105.1 204.204.7.2

Lab-A(config)#ip host Lab-E 210.93.105.2

Lab-A(config)#control z

Page 28: Configuring Routers

Turn on the interfaces:

• Lab-A(config)#interface s0

• Lab-A(config-if)#no shutdown

• Lab-A(config-if)#interface e0

• Lab-A(config-if)#no shutdown

• Lab-A(config-if)#interface e1

• Lab-A(config-if)#no shutdown

Step Seven

Page 29: Configuring Routers

For Lab-A router, you are through!

Page 30: Configuring Routers

Program the other routers the same way, BUT:

• Use the interfaces in use on each particular router

• Use the correct ip address/network address for each port on that router

• Check and save your configuration!• Router#show run (Check)• Router#copy run start (Save)

Page 31: Configuring Routers

Let’s Review:

• Step 1 – name router

• Hostname xxxxx

• Step 2 – set “privilege” password and encode it

• Enable secret xxxxx

• Step 3 – configure interfaces

• Interface sX (or eX)

Page 32: Configuring Routers

• Step 4 – Set the routing protocols

• Router rip

• Step 5 – Set who and where access comes from

• Line console (vty)

• Step 6 – Save Time

• Ip host xxx.xxx.xxx yyy.yyy.yyy

• Step 7 – Turn on interfaces

• Router(config-if)#no shutdown

Page 33: Configuring Routers

Check and Save your work!

• Check your config

• Router#show run

• Save your configuration from RAM to NVRAM

• Router#copy run start

Page 34: Configuring Routers

You’re Through!